Examples: Monday, today, last week, Mar 26, 3/26/04

TP-Link smart plugs - don't forget to update for DST!

For whatever reason, it appears TP-Link smart plugs don't automatically adjust for DST. I figured this out during an OhmHour on Sunday right after the time change, when I noticed my devices hadn't turned off.

To adjust:

Go to the Kasa app > Settings> Location and Time > Time Zone > Change to PDT in March or PST in November

Now check your device's time by tapping each device > click the gear icon > and verify that the "device time" is correct.

Good luck!

Comments

  • SrelazSrelaz FullertonPosts: 105Member

    Thank you, I was getting a little P/O'd because my smart plugs weren't shutting off and I was manually killing all my individual circuit breakers. I don't remember having to do during the changes last fall or spring?!?!

  • Andrew FarrisAndrew Farris Posts: 5Member
    Thanks this wrecked my results today.
  • rbarlinerbarline Posts: 9Member

    Same here. I even asked OhmConnect support why my smartplug was not turning off and they did not know. It was only after my own investigations that I discovered that the "device time" showing in settings (in the Kasa app window) for my smartplug was an hour early. I contacted TP-Link support for help to resolve this, and they gave me the instructions here (www.tp-link.com/us/faq-1481.html). Note that Kasa has two "settings" icons, one for you as a user, and another for each individual device. The "Location and Time" setting is part of the user settings (three bars in the upper left corner of the home window). Now that my device time is reading correctly, I'm hoping my smartplug will turn off automatically from now on. If it does, then mystery solved.

Sign In or Register to comment.