Examples: Monday, today, last week, Mar 26, 3/26/04

latest rebate offer

I ordered the smart plug when it was offered for free last week. it said rebae to be awarded once connected. I connected it and no points were given :-(
«1

Comments

  • UkiwiSUkiwiS San DiegoPosts: 1,558Member, Moderator
    > @papascents said:
    > I ordered the smart plug when it was offered for free last week. it said rebae to be awarded once connected. I connected it and no points were given :-(

    How long ago did you connect it?
  • samkleesamklee Posts: 71Member, Administrator, Moderator

    @papascents said:
    I ordered the smart plug when it was offered for free last week. it said rebae to be awarded once connected. I connected it and no points were given :-(

    You should be good to go now. Write us if you notice any other issues with your account.

    Sam

  • papascentspapascents Posts: 3Member
    thank you so much Sam and OHMConnect
    got my rebate and loving the saving energy
  • Miriam BarlowMiriam Barlow Posts: 1Member

    Hi I ordered a smart plug when the rebate offer came up and I think my rebate came as Ohmstore credit instead of points to my account. Is there a way I get points instead of store credit?

  • W94565W94565 Posts: 5Member

    I ordered the smart plug when it was offered for free last week. It said rebate to be awarded once connected. I connected it and no points were given.

  • UkiwiSUkiwiS San DiegoPosts: 1,558Member, Moderator

    @Paul94565 said:
    I ordered the smart plug when it was offered for free last week. It said rebate to be awarded once connected. I connected it and no points were given.

    Did you wait a day or two for it to show up?

  • dslaidslai Posts: 27Member

    How long does it normally take to receive the points rebate for the smart plug offer after installing it? I installed mine 3 days ago and connected it to my OhmConnect account. But still haven't received any points for it. This FAQ article http://faq.ohmconnect.com/ohmconnect-store/i-ordered-a-device-where-is-my-rebate implies that points should be awarded within 24 hours and states to contact support if they aren't. So I did and sent an inquiry to the chat to ask about this. The reply I got back was a link to the same FAQ article. I replied back to this stating the obvious and am waiting for another response.

  • UkiwiSUkiwiS San DiegoPosts: 1,558Member, Moderator

    @samklee

    Can you please check the rebate status for @dslai @UkiwiS @Paul94565 @Bstring. Those are the ones I know of but there are probably many more.

  • samkleesamklee Posts: 71Member, Administrator, Moderator

    @UkiwiS said:
    @samklee

    Can you please check the rebate status for @dslai @UkiwiS @Paul94565 @Bstring. Those are the ones I know of but there are probably many more.

    Yep, I'll check it out. Won't be able to look at it until later in the afternoon. I'll update this thread then.

  • ScYuScYu Posts: 8Member
    edited November 2018

    I also connected the smart plug and added to my Ohmconnect account, but my points balance is not updating. Thanks

    UPDATE: points deposited after a couple days

  • dslaidslai Posts: 27Member

    I got the points for this rebate offer today. So it took about 1 week after I installed/connected the smart plug to my account. Not sure if that's the normal timeframe or because of posting in this thread and having someone look into these issues for certain users including myself.

  • dentriesdentries Posts: 1Member

    It looks that this is a common problem. I connected the 'free' device more than 120 hours ago and still there is no sign of the rebate (points). Reaching out to them with this issue gets you only a referral to the FAQ article which is not helpful. Despite me telling them the article does not help, I still get referred to it everything I tell them that the points have not been awarded to me.

  • UkiwiSUkiwiS San DiegoPosts: 1,558Member, Moderator

    @samklee

    Yep, I'll check it out. Won't be able to look at it until later in the afternoon. I'll update this thread then.

    Any update?

  • Zephyr2015Zephyr2015 Posts: 4Member

    I connected my a few days ago and didn't get credited either. Previously bonus points for connected devices would credit almost instantly.

  • samkleesamklee Posts: 71Member, Administrator, Moderator

    @UkiwiS said:

    @samklee

    Yep, I'll check it out. Won't be able to look at it until later in the afternoon. I'll update this thread then.

    Any update?

    Yep, sorry for not getting back to this thread. We have an engineering ticket on the issue. The issue coincides with our shipping the largest amount of smart devices in our history over the last week or so, which is fantastic to see users heading towards optimizing their homes with smart plugs. But this also exposes weaknesses / bugs in our system. Everyone will be updated with their rebates when a fix rolls out, as we have a list compiled of users affected by the issue.

  • XdatineliaXdatinelia Posts: 44Member
    Add me to this list also, just connected plug today.
  • Please add me to this list, connected plug today.

  • prabhakaprabhaka Posts: 10Member

    This was posted on the closed discussion thread.

    https://forum.ohmconnect.com/discussion/2059/haven-t-recieved-rest-of-smart-plug-rebate#latest

    Today is 21st and i haven't received rest of the rebate..
    I did send an email to support but the only response i got was without anything else but a URL to FAQ, that mentions "make sure to apply discount code when purchasing the device". which i did and got 50% off while getting it from store.

    what i haven't received is the rest of the 50%, even after i was told it would be done in 24 hours on 19th.

  • CraigWCraigW Posts: 44Member
    edited November 2018

    Mine came in the yesterday. Now where to put it since it will block both outlets... :-(

    Now as I try and read the 'manual' that is printed in 2pt font in the box. Is there a way to control this device without creating a KASA account and basically granting yet another corporation or two access and visibility to my network passwords?

    Oh yippie, their tech support says I basically have to set up through their app. With an account and then program through their app to access my network. Ridiculous security posture.

  • samkleesamklee Posts: 71Member, Administrator, Moderator

    @CraigW said:
    Mine came in the yesterday. Now where to put it since it will block both outlets... :-(

    Now as I try and read the 'manual' that is printed in 2pt font in the box. Is there a way to control this device without creating a KASA account and basically granting yet another corporation or two access and visibility to my network passwords?

    Oh yippie, their tech support says I basically have to set up through their app. With an account and then program through their app to access my network. Ridiculous security posture.

    Hi @CraigW, totally understand the security concerns, but unfortunately, we're constrained by TP-Link's API policy. While it's not apparent, we do our best to make the device connection process as seamless and easy as possible.

    I'm not sure we've actually shared before how we pick our devices on our storefront, but as a recent, new employee I was impressed at what our device guys do in testing and researching various smart plugs, etc. In short, we order essentially everything available in the U.S. market regularly and actually bring the devices home and use them in real-world situations. We also spend some time and actually force the devices into various scenarios to see how they "fail" in performing their intended design.

    What you see on the store are the devices that created the fewest problems and worked the best in a wide variety of situations. While they are not perfect in every instance, they are the best of what's available currently.

  • samkleesamklee Posts: 71Member, Administrator, Moderator

    Hi Everyone, as of this writing (11/25) everyone mentioned on this thread with rebate issues have been addressed. Let me know if anyone needs help with anything else.

  • UkiwiSUkiwiS San DiegoPosts: 1,558Member, Moderator

    @samklee

    I can confirm I have received mine.

    Going forward, will it be added automatically or was this just a manual fix for those that complained about it in the forum?

  • UkiwiSUkiwiS San DiegoPosts: 1,558Member, Moderator

    @samklee

    In other words, If I buy another one of these, will I be waiting another month for the refund?

  • CraigWCraigW Posts: 44Member

    @samklee I've connected it. Fortunately, the tech support from TP-Link was wrong. I was able to bypass the account for the set up of the device itself. Still had to use their app, but did't need an account until I wanted to enable remote control.

    While I appreciate easy setup, it is unfortunately what concerns me the most from a security standpoint.

  • SD ChipSD Chip Posts: 142Member

    @samklee said:
    Hi Everyone, as of this writing (11/25) everyone mentioned on this thread with rebate issues have been addressed. Let me know if anyone needs help with anything else.

    Hello @samklee. I have also connected my new smart plug that I obtained through the promotion, however I have not received the rebate. Any help you can give would be truly appreciated.

  • samkleesamklee Posts: 71Member, Administrator, Moderator

    @SD Chip said:

    @samklee said:
    Hi Everyone, as of this writing (11/25) everyone mentioned on this thread with rebate issues have been addressed. Let me know if anyone needs help with anything else.

    Hello @samklee. I have also connected my new smart plug that I obtained through the promotion, however I have not received the rebate. Any help you can give would be truly appreciated.

    Yep, messaged!

  • samkleesamklee Posts: 71Member, Administrator, Moderator

    @UkiwiS said:
    @samklee

    In other words, If I buy another one of these, will I be waiting another month for the refund?

    You will absolutely not have to wait for your rebate points. Just give me a heads up when you receive the device.

  • samkleesamklee Posts: 71Member, Administrator, Moderator

    @UkiwiS said:
    @samklee

    I can confirm I have received mine.

    Going forward, will it be added automatically or was this just a manual fix for those that complained about it in the forum?

    This was a manual fix. We have an engineering ticket in place but I can tell you that the fix going forward is going to be elusive since it is only affecting a small number of our users. :(

    To everyone else, just give me a shoutout if you're not receiving your rebate points within 24 hours of connecting the device and I'll take care of you.

  • CraigWCraigW Posts: 44Member

    Alright, I've received my rebate. I can see my device as connected on the devices tab.

    However 15 minutes into the Oh, nothing has happened. It hasn't turned off the plug. I can manually turn off the plug in the device tab so that works.

    So is there something else I need to do?

Sign In or Register to comment.